Friday, February 26, 2010

Truck status, hanging starter

Work has had me absolutely slammed. 17 hours on Sunday, probably because it's getting hard to think straight and I'm just getting slow. I'd rather be slinging code for that amount of time.

Saga not quite over yet, but waiting until it's solved and I can objectively review the situation. I will post an update.

The truck's not quite running right. It finally passed emissions with flying colors, but needs a "VSV" valve to do it again (how is this passing? Well it at least let me satisfy DMV and get the title finished over to my name.). I'm told Toyota don't make it anymore, but the dealer I called could get both VSV valves in a couple of days, so I need to follow up and find out what valve it really needs.

The shop also felt my O2 sensor was slow, so they swapped in a new one. The TEC turbo comes with a larger-than-stock O2 bung, so they installed a GM unit they felt was compatible. At light cruise on the highway, in any gear, it now feels like it's experiencing a lean surge, and gets jerky. Give it a little throttle and it goes away.

Gas MPG went up from 14 to 18, but then dropped back to 15 the next tank. This tank seems to be doing better. Neither one is the mileage I was hoping for, especially with 225s, no lift, and no ability to light 'em up down the block (it's a total dog off the lights and I can't imagine it being able to do a brake-stand).

The truck is running better under power since they looked at it last, tho. By the time I cross the intersection, it's starting to pull. But, again, not the power I was hoping for. 2.4 liters, turbocharged should be not that far off from my M3 (3.0 I6 240hp in US dress, 321hp if it was the Euro version). I'll give BMW credit, their German horses seem to be a lot bigger than these Japanese horses, the car pulls 23mpg driving it assertively, dipping to 19 if I'm really blurring the scenery, or a high of 28 if it's all slab.  Almost 10mpg on a track day where the carpet is compressed all day long. I can't begin to imagine selling that car, it's such a great all-arounder.

The Toy's gearing and power band is great for cruising down the highway at 70-80+ though, which is important as there are big stretches of pavement between the dirt. However, hills and the OD are unhappy together. I need to shift out of overdrive several times on my way home, which I don't need to do in SWMBO's Yukon XL unless I'm in a hurry.

My goal was to build an engine that got good gas mpg, wasn't a twitchy monster offroad, but had decent power while getting out to the trails. We're not quite there yet...

OTOH, the Toy's stock turbo 2.4 was a meager 145hp... I'm looking forward to a dyno run, and I'll look for some online advice on what other changes I can make.

The turbo is leaking. Could be because the drain line was kinked, causing the truck to puff smoke coming to a stop, could just be a rebuild problem. Shop seems to be taking care of it (there was a question at one time), so that'll be cool (and one reason I paid instead of DIY. I hardly have time to drop the thing off again.)

The starter has started hanging (keeps trying to start after you release the key) so I'll be using these two links to see if I can sort out the problem. It's either a sticky contact or a sticky plunger.

It's off to the shop. Any bets how long they have it this time? :)